|SLOWCGI(8)||System Manager's Manual||SLOWCGI(8)|
slowcgiis a server which implements the FastCGI Protocol to execute CGI scripts. FastCGI was designed to overcome the CGI protocol's scalability and resource sharing limitations. While CGI scripts need to be forked for every request, FastCGI scripts can be kept running and handle many HTTP requests.
slowcgi is a simple server that translates
FastCGI requests to the CGI protocol. It executes the requested CGI script
and translates its output back to the FastCGI protocol.
Modern web frameworks and web applications usually come with the
capability to run as FastCGI servers.
slowcgi is not
intended for these applications.
slowcgi opens a socket at
/var/www/run/slowcgi.sock, owned by www:www, with
permissions 0660. It will then chroot(8)
to /var/www and drop privileges to user
The options are as follows:
slowcgiwill run in the foreground and log to stderr.
D. Robinson, K. Coar, The Common Gateway Interface (CGI) Version 1.1, RFC 3875, October 2004.
slowcgiserver first appeared in OpenBSD 5.4. Florian Obser <email@example.com>
slowcgionly implements the parts of the FastCGI standard needed to execute CGI scripts. This is intentional.
|August 13, 2018||OpenBSD-current|